Вы должны войти, чтобы создавать сообщения и темы.

Вопрос по УНФ: Как вывести содержимое кассового чека на второй экран?

Здравствуйте! Подскажите пожалуйста в какой именно обработке находится необходимая форма в конфигурации УНФ?

В поставке нет такой обработки.

Недавно делали для клиента расширение для УНФ.
Можете взять и доработать если надо.

В расширении еще есть кнопка вывода состава расходной накладной на складской дисплей.

Вырежете если не надо.

http://www.rbsoft.ru/download/md-for-unf/

 

Создать в справочнике настроек медиадисплеев элемент.

Прочитать подсказки к полям и заполнить.

Сначала верно заполнить адрес сервера медиадисплеев.

После этого кнопки выбора темы, имени дисплея будут работать.

 

Кнопки тестов (с синей стрелкой)  вызывают процедуры тестового вывода на экран.

Например, вот так:

 

Из текста процедуры можно понять, как пользоваться выводом информации.

Примеры

Вывод тестового чека.

&НаКлиенте
Процедура ТестПриветствия(Команда)
  Задание = рбсОбщийМодуль.ПолучитьТестовоеЗадание();
  Задание.Заголовок = Объект.ТекстПриветствия;
  ТекстОшибки="";
  Если НЕ рбсМедиадисплей.ВывестиЧек(Объект.Адрес,Объект.ИмяДисплея,Задание,ТекстОшибки) Тогда
    Сообщить("Ошибка при выводе на дисплей: "+ТекстОшибки);
  КонецЕсли;	
  
КонецПроцедуры

Текст функций ПолучитьТестовоеЗадание из модуля рбсОбщийМодуль.

Функция ПолучитьСтруктуруТовара() экспорт
  Структура = Новый Структура;
  Структура.Вставить("НомерСтроки",0);
  Структура.Вставить("Наименование","");
  Структура.Вставить("Количество",0);
  Структура.Вставить("Цена",0);
  Структура.Вставить("Сумма",0);
  Структура.Вставить("СуммаСкидки",0);
  
  возврат Структура;
КонецФункции	

//возвращает структуру задания для отображения чека
Функция ПолучитьСтруктуруЗаданияЧек() Экспорт
  Структура = Новый Структура;
  
  Структура.Вставить("Заголовок","Добро пожаловать!");//срока приветствия. "Добро пожаловать!" или "Спасибо за покупку!"
  Структура.Вставить("Инфо","Добро
  |пожаловать!"); //Строки для двустрочного режима. Может быть многострочный текст
  
  
  Структура.Вставить("СуммаБезСкидки",0);
  Структура.Вставить("СуммаСкидки",0);
  Структура.Вставить("СуммаИтого",0);
  Структура.Вставить("Оплачено",0);
  Структура.Вставить("Сдача",0);
  Структура.Вставить("НомерВыделеннойСтроки",-1);
  
  ТЗ = Новый Массив;
  Структура.Вставить("Товары",ТЗ);
  
  возврат Структура;
КонецФункции

//возвращает структуру тестового задания. 
//Параметры:
//Пример =1,2
Функция ПолучитьТестовоеЗадание(Пример=1) экспорт
  
  Задание = ПолучитьСтруктуруЗаданияЧек();
  
  //Выводим товар
  Товар = ПолучитьСтруктуруТовара();
  Товар.НомерСтроки=1;
  Товар.Наименование="Омуль байкальский. Малосольный";
  Товар.Количество=1.234;
  Товар.Цена=450;
  Товар.Сумма=555.30;
  Товар.СуммаСкидки=10.50;
  Задание.Товары.Добавить(Товар);
  
  //Выводим товар
  Товар = ПолучитьСтруктуруТовара();
  Товар.НомерСтроки=2;
  Товар.Наименование="Икра омулевая";
  Товар.Количество=2;
  Товар.Цена=300;
  Товар.Сумма=600;
  Товар.СуммаСкидки=50;
  Задание.Товары.Добавить(Товар);
  
  //Выводим товар
  Товар = ПолучитьСтруктуруТовара();
  Товар.НомерСтроки=3;
  Товар.Наименование="Масло сливочное. Высший сорт.";
  Товар.Количество=3;
  Товар.Цена=150;
  Товар.Сумма=450;
  Задание.Товары.Добавить(Товар);
  
  //Выводим товар
  Товар = ПолучитьСтруктуруТовара();
  Товар.НомерСтроки=4;
  Товар.Наименование="Батон нарезной";
  Товар.Количество=1;
  Товар.Цена=30;
  Товар.Сумма=30;
  Задание.Товары.Добавить(Товар);
  
  //Выводим итоги
  Задание.СуммаБезскидки=1635.30;
  Задание.СуммаСкидки=60.50;
  Задание.СуммаИтого=1574.80;
  
  Если Пример=1 Тогда
    //Выводим заголовки
    Задание.Заголовок="www.rbsoft.ru";
    Задание.Инфо="ДОБРО
          |ПОЖАЛОВАТЬ!";
    Задание.Оплачено=0;
    Задание.Сдача=0;
    
    Задание.НомерВыделеннойСтроки=0; //выделяем ПЕРВУЮ строку
    
  ИначеЕсли Пример=2 Тогда
    //Выводим заголовки
    Задание.Заголовок="1С+Digital Signage";
    Задание.Инфо="СПАСИБО
    |ЗА ПОКУПКУ!";
    
    Задание.НомерВыделеннойСтроки=1; //выделяем ВТОРУЮ строку
    Задание.Оплачено=2000;
    Задание.Сдача=425.2;
  КонецЕсли;
  
  
  возврат Задание;
КонецФункции	

Как видно из текста - нам надо просто заполнить нашими данными структуру чека и вызвать функцию рбсМедиадисплей.ВывестиЧек()

Авторизация
*
*

7 − четыре =

Регистрация
*
*
*

5 × три =

Генерация пароля

14 − тринадцать =