РБ-Софт

Как мы можем помочь?

Содержание

Сервер ККМ. УТ10.3. Печать чеков с маркировкой шин.

< Назад

Условия

1. Применяем «1С:Управление торговлей», редакция 10.3 (10.3.66.3)

2. Печатаем чеки с применением «РБ-Софт:Сервер ККМ».

3. Торгуем шинами.


Проблема

Чеки не выводят код маркировки для шин.

Решение

Для включения возможности печати чеков с маркировкой шин необходимо внести небольшое изменение в программный код конфигурации 1С:Управление торговлей 10.

В общем модуле ИнтеграцияИСКлиентСервер найдите функцию ТипМаркировкиККТПоВидуПродукции.

Она следующего вида:

Функция ТипМаркировкиККТПоВидуПродукции(ТипМаркировкиККТИлиВидПродукции) Экспорт
	
	Если ТипМаркировкиККТИлиВидПродукции = ПредопределенноеЗначение("Перечисление.ТипыМаркировкиККТ.ТабачнаяПродукция") Тогда
		Возврат ПредопределенноеЗначение("Перечисление.ВидыПродукцииИС.Табак");
	ИначеЕсли ТипМаркировкиККТИлиВидПродукции = ПредопределенноеЗначение("Перечисление.ТипыМаркировкиККТ.ОбувныеТовары") Тогда
		Возврат ПредопределенноеЗначение("Перечисление.ВидыПродукцииИС.Обувь");
	ИначеЕсли ТипМаркировкиККТИлиВидПродукции = ПредопределенноеЗначение("Перечисление.ВидыПродукцииИС.Табак") Тогда
		Возврат ПредопределенноеЗначение("Перечисление.ТипыМаркировкиККТ.ТабачнаяПродукция");
	ИначеЕсли ТипМаркировкиККТИлиВидПродукции = ПредопределенноеЗначение("Перечисление.ВидыПродукцииИС.Обувь") Тогда
		Возврат ПредопределенноеЗначение("Перечисление.ТипыМаркировкиККТ.ОбувныеТовары");
	Иначе
		Возврат Неопределено;
	КонецЕсли;
	
КонецФункции

Если конфигурация стоит на поддержке, то необходимо включить возможность изменения у данного модуля.
Необходимо привести функцию к виду:

Функция ТипМаркировкиККТПоВидуПродукции(ТипМаркировкиККТИлиВидПродукции) Экспорт
	
	Если ТипМаркировкиККТИлиВидПродукции = ПредопределенноеЗначение("Перечисление.ТипыМаркировкиККТ.ТабачнаяПродукция") Тогда
		Возврат ПредопределенноеЗначение("Перечисление.ВидыПродукцииИС.Табак");
	ИначеЕсли ТипМаркировкиККТИлиВидПродукции = ПредопределенноеЗначение("Перечисление.ТипыМаркировкиККТ.ОбувныеТовары") Тогда
		Возврат ПредопределенноеЗначение("Перечисление.ВидыПродукцииИС.Обувь");
	ИначеЕсли ТипМаркировкиККТИлиВидПродукции = ПредопределенноеЗначение("Перечисление.ВидыПродукцииИС.Табак") Тогда
		Возврат ПредопределенноеЗначение("Перечисление.ТипыМаркировкиККТ.ТабачнаяПродукция");
	ИначеЕсли ТипМаркировкиККТИлиВидПродукции = ПредопределенноеЗначение("Перечисление.ВидыПродукцииИС.Обувь") Тогда
		Возврат ПредопределенноеЗначение("Перечисление.ТипыМаркировкиККТ.ОбувныеТовары");
	//РБ-Софт+ Добавления работы с шинами	
	ИначеЕсли ТипМаркировкиККТИлиВидПродукции = ПредопределенноеЗначение("Перечисление.ВидыПродукцииИС.Шины") Тогда
		Возврат ПредопределенноеЗначение("Перечисление.ТипыМаркировкиККТ.ОбувныеТовары");
	//РБ-Софт-	
	Иначе
		Возврат Неопределено;
	КонецЕсли;
	
КонецФункции

После изменений коды маркировки будут передаваться на ККМ.

Печать маркировки на текущий момент (21/12/2020) работает для ККМ Атол.
Для ККМ Штрих и VikiPrint производится доработка сервера ККМ.

Предыдущая Сервер ККМ. Подключение к 1С: УТ 10.3, КА 1.1, УПП 1.3.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Авторизация
*
*
Регистрация
*
*
*
Генерация пароля